#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@[1-3a-di-ns-ux-z.]{3,5}[\s]"
Local $sString = "@abc @ijmn @123 @1a2b @abc.a @stu @x.yz @klm @2c3d" & @CRLF & _
"" & @CRLF & _
"@a @ab @abc a@xyz !@ijmn,@123 0@321 @1a2b @qwerty @abc.a @stu..test _@nmp @x.yz.@klm @.1a2b .@2c3d." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")