// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@[1-3a-di-ns-ux-z.]{3,5}[\s]").unwrap();
let string = "@abc @ijmn @123 @1a2b @abc.a @stu @x.yz @klm @2c3d
@a @ab @abc a@xyz !@ijmn,@123 0@321 @1a2b @qwerty @abc.a @stu..test _@nmp @x.yz.@klm @.1a2b .@2c3d.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}