package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@[1-3a-di-ns-ux-z.]{3,5}[\s]`)
var str = `@abc @ijmn @123 @1a2b @abc.a @stu @x.yz @klm @2c3d
@a @ab @abc a@xyz !@ijmn,@123 0@321 @1a2b @qwerty @abc.a @stu..test _@nmp @x.yz.@klm @.1a2b .@2c3d.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}