$re = '/@[1-3a-di-ns-ux-z.]{3,5}[\s]/m';
$str = '@abc @ijmn @123 @1a2b @abc.a @stu @x.yz @klm @2c3d
@a @ab @abc a@xyz !@ijmn,@123 0@321 @1a2b @qwerty @abc.a @stu..test _@nmp @x.yz.@klm @.1a2b .@2c3d.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);