using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\s|^)([a-z])\2+)(?=\s|$)|([a-z])(?=\3)";
string substitution = @"$1";
string input = @"aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa
#$aa$aa#aaa bbb
aaa aaa
test aaaaa aaaaa aaaa
aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}