import re
regex = re.compile(r"((?:\s|^)([a-z])\2+)(?=\s|$)|([a-z])(?=\3)")
test_str = ("aaa baaab xxx\n"
"ahhj aaab cc iiik\n"
"bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa\n\n"
"#$aa$aa#aaa bbb\n"
"aaa aaa\n\n"
"test aaaaa aaaaa aaaa\n"
" aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)