const regex = /((?:\s|^)([a-z])\2+)(?=\s|$)|([a-z])(?=\3)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\s|^)([a-z])\\2+)(?=\\s|$)|([a-z])(?=\\3)', 'g')
const str = `aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa
#\$aa\$aa#aaa bbb
aaa aaa
test aaaaa aaaaa aaaa
aaa aaa d\$test#dd!aaaa\$ddd !dd#fdg5\$hhaaa^%bb zzzzz`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);