use strict;
my $str = 'aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa
#$aa$aa#aaa bbb
aaa aaa
test aaaaa aaaaa aaaa
aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz';
my $regex = qr/((?:\s|^)([a-z])\2+)(?=\s|$)|([a-z])(?=\3)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";