$re = '/((?:\s|^)([a-z])\2+)(?=\s|$)|([a-z])(?=\3)/';
$str = 'aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa
#$aa$aa#aaa bbb
aaa aaa
test aaaaa aaaaa aaaa
aaa aaa d$test#dd!aaaa$ddd !dd#fdg5$hhaaa^%bb zzzzz';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;