#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:[^\|]\|)([^\|]+)(?:\|\|)"
Local $sString = "машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)