package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^\|]\|)([^\|]+)(?:\|\|)`)
var str = `машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}