import Foundation
let pattern = #"(?:[^\|]\|)([^\|]+)(?:\|\|)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)