re = /(?:[^\|]\|)([^\|]+)(?:\|\|)/
str = 'машина|жигули, тойота, ваз, заз||техника|мясорубка, телевизор, телефон, Q123||фрукты|яблоко, апельсин, банан, анонс, маракуя1||'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result