const regex = new RegExp('^(?:en/)?\\d{1,3}-[^/]+/$', 'gm')
const str = `12-blog/
12-blog/blog2/
en/12-blog/
en/12-blog/blog2/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}