// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:en/)?\d{1,3}-[^/]+/$").unwrap();
let string = "12-blog/
12-blog/blog2/
en/12-blog/
en/12-blog/blog2/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}