$re = '`^(?:en/)?\d{1,3}-[^/]+/$`m';
$str = '12-blog/
12-blog/blog2/
en/12-blog/
en/12-blog/blog2/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);