#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\s+(.+?)\s+\((\d+ matches)"
Local $sString = " 10 permit 10.8.1.26 (1284 matches)" & @CRLF & _
" 20 permit 10.8.2.200 (22 matches)" & @CRLF & _
" 30 permit 10.8.3.200 (160 matches)" & @CRLF & _
" 40 permit ip host 10.8.1.26 any" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")