package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s+(.+?)\s+\((\d+ matches)`)
var str = ` 10 permit 10.8.1.26 (1284 matches)
20 permit 10.8.2.200 (22 matches)
30 permit 10.8.3.200 (160 matches)
40 permit ip host 10.8.1.26 any
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}