import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s+(.+?)\\s+\\((\\d+ matches)";
final String string = " 10 permit 10.8.1.26 (1284 matches)\n"
+ " 20 permit 10.8.2.200 (22 matches)\n"
+ " 30 permit 10.8.3.200 (160 matches)\n"
+ " 40 permit ip host 10.8.1.26 any\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}