using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s+(.+?)\s+\((\d+ matches)";
string input = @" 10 permit 10.8.1.26 (1284 matches)
20 permit 10.8.2.200 (22 matches)
30 permit 10.8.3.200 (160 matches)
40 permit ip host 10.8.1.26 any
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}