re = /(\d+)\s+(.+?)\s+\((\d+ matches)/m
str = ' 10 permit 10.8.1.26 (1284 matches)
20 permit 10.8.2.200 (22 matches)
30 permit 10.8.3.200 (160 matches)
40 permit ip host 10.8.1.26 any
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end