using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.(?<!\n\n))*BAD((?!\n\n).)*";
string substitution = @"GOOD";
string input = @"dfsdf
sdfdf
blablabla
blaBAD
bla
dsfsdf
sdfdf";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}