import re
regex = re.compile(r"(.(?<!\n\n))*BAD((?!\n\n).)*")
test_str = ("dfsdf\n"
"sdfdf\n\n"
"blablabla\n"
"blaBAD\n"
"bla\n\n"
"dsfsdf\n"
"sdfdf")
subst = "GOOD"
result = regex.sub(subst, test_str)
if result:
print(result)