re = /(.(?<!\n\n))*BAD((?!\n\n).)*/
str = 'dfsdf
sdfdf
blablabla
blaBAD
bla
dsfsdf
sdfdf'
subst = 'GOOD'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result