import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.(?<!\\n\\n))*BAD((?!\\n\\n).)*";
final String string = "dfsdf\n"
+ "sdfdf\n\n"
+ "blablabla\n"
+ "blaBAD\n"
+ "bla\n\n"
+ "dsfsdf\n"
+ "sdfdf";
final String subst = "GOOD";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}