$re = '/(.(?<!\n\n))*BAD((?!\n\n).)*/';
$str = 'dfsdf
sdfdf
blablabla
blaBAD
bla
dsfsdf
sdfdf';
$subst = "GOOD";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;