#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^AttributeReferenceID\s+)(\d+)"
Local $sString = "AttributeReferenceID 123" & @CRLF & _
"AttributeReferenceID 456" & @CRLF & _
"AttributeReferenceID 789" & @CRLF & _
"ISCCAttributeReferenceID 091281 [09123na0]" & @CRLF & _
"ISCCAttributeReferenceID 123012 [i1208221]" & @CRLF & _
"ISCCAttributeReferenceID 091221 [0oas9019]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")