use strict;
my $str = 'AttributeReferenceID 123
AttributeReferenceID 456
AttributeReferenceID 789
ISCCAttributeReferenceID 091281 [09123na0]
ISCCAttributeReferenceID 123012 [i1208221]
ISCCAttributeReferenceID 091221 [0oas9019]';
my $regex = qr/(?:^AttributeReferenceID\s+)(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}