const regex = /(?:^AttributeReferenceID\s+)(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^AttributeReferenceID\\s+)(\\d+)', 'gm')
const str = `AttributeReferenceID 123
AttributeReferenceID 456
AttributeReferenceID 789
ISCCAttributeReferenceID 091281 [09123na0]
ISCCAttributeReferenceID 123012 [i1208221]
ISCCAttributeReferenceID 091221 [0oas9019]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}