import re
regex = re.compile(r"(?:^AttributeReferenceID\s+)(\d+)", flags=re.MULTILINE)
test_str = ("AttributeReferenceID 123\n"
"AttributeReferenceID 456\n"
"AttributeReferenceID 789\n"
"ISCCAttributeReferenceID 091281 [09123na0]\n"
"ISCCAttributeReferenceID 123012 [i1208221]\n"
"ISCCAttributeReferenceID 091221 [0oas9019]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")