package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^AttributeReferenceID\s+)(\d+)`)
var str = `AttributeReferenceID 123
AttributeReferenceID 456
AttributeReferenceID 789
ISCCAttributeReferenceID 091281 [09123na0]
ISCCAttributeReferenceID 123012 [i1208221]
ISCCAttributeReferenceID 091221 [0oas9019]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}