import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+=\"<([a-z0-9]+)>(\\n|\\r|\\f|\\s)*Título(\\n|\\r|\\f|\\s)*<\\/\\1>\"";
final String string = "<div id=\"myId\"><h3 innerHTML=\"<span> \n"
+ "Título\n"
+ "</span>\"></h3></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}