$re = '/[a-zA-Z]+="<([a-z0-9]+)>(\n|\r|\f|\s)*Título(\n|\r|\f|\s)*<\/\1>"/';
$str = '<div id="myId"><h3 innerHTML="<span>
Título
</span>"></h3></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);