re = /[a-zA-Z]+="<([a-z0-9]+)>(\n|\r|\f|\s)*Título(\n|\r|\f|\s)*<\/\1>"/
str = '<div id="myId"><h3 innerHTML="<span>
Título
</span>"></h3></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end