#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=GROOT\s.).[0-9]+"
Local $sString = "1) I AM GROOT" & @CRLF & _
"2) GROOT" & @CRLF & _
"3) GROOT IS MY PET’S NAME" & @CRLF & _
"4) GROOT’S HAPPY" & @CRLF & _
"5) GROOT - 25442421321"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")