import re
regex = re.compile(r"(?<=GROOT\s.).[0-9]+", flags=re.MULTILINE)
test_str = ("1) I AM GROOT\n"
"2) GROOT\n"
"3) GROOT IS MY PET’S NAME\n"
"4) GROOT’S HAPPY\n"
"5) GROOT - 25442421321")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")