import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=GROOT\\s.).[0-9]+";
final String string = "1) I AM GROOT\n"
+ "2) GROOT\n"
+ "3) GROOT IS MY PET’S NAME\n"
+ "4) GROOT’S HAPPY\n"
+ "5) GROOT - 25442421321";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}