using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=GROOT\s.).[0-9]+";
string input = @"1) I AM GROOT
2) GROOT
3) GROOT IS MY PET’S NAME
4) GROOT’S HAPPY
5) GROOT - 25442421321";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}