$re = '/(?<=GROOT\s.).[0-9]+/m';
$str = '1) I AM GROOT
2) GROOT
3) GROOT IS MY PET’S NAME
4) GROOT’S HAPPY
5) GROOT - 25442421321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);