using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(email|name)\s*([><]=?|!?=)\s*(.*?)(?=\s*(?:(?:email|name)\s*(?:[><]=?|!?=)|$))";
string input = @"bla bla bla lorem ipsum bla bla email=destiney41@leuschke.org name!=Foo Bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}