import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(email|name)\\s*([><]=?|!?=)\\s*(.*?)(?=\\s*(?:(?:email|name)\\s*(?:[><]=?|!?=)|$))";
final String string = "bla bla bla lorem ipsum bla bla email=destiney41@leuschke.org name!=Foo Bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}