const regex = /(email|name)\s*([><]=?|!?=)\s*(.*?)(?=\s*(?:(?:email|name)\s*(?:[><]=?|!?=)|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(email|name)\\s*([><]=?|!?=)\\s*(.*?)(?=\\s*(?:(?:email|name)\\s*(?:[><]=?|!?=)|$))', 'gm')
const str = `bla bla bla lorem ipsum bla bla email=destiney41@leuschke.org name!=Foo Bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}