$re = '/(email|name)\s*([><]=?|!?=)\s*(.*?)(?=\s*(?:(?:email|name)\s*(?:[><]=?|!?=)|$))/m';
$str = 'bla bla bla lorem ipsum bla bla email=destiney41@leuschke.org name!=Foo Bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);