re = /(email|name)\s*([><]=?|!?=)\s*(.*?)(?=\s*(?:(?:email|name)\s*(?:[><]=?|!?=)|$))/m
str = 'bla bla bla lorem ipsum bla bla email=destiney41@leuschke.org name!=Foo Bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end