using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*?)(?:, )?([a-zéèàçù -]+?)\n(\d\d ?\d\d\d) ([a-z- ]+?)$";
string input = @"61, avenue de Gauthier
81 516 Michel-sur-Paris
6, boulevard de Nguyen
02 998 Techer
boulevard Lucie Bouvet
16 345 Morel-sur-Marques
7, impasse Francois
29172 Deschampsnec
30, place Lucy Guillot
94 786 Texier-sur-Rolland
rue de Pruvost
91 147 Brun
boulevard Amélie Martin
56243 Godard
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}