import Foundation
let pattern = #"^(\d*?)(?:, )?([a-zéèàçù -]+?)\n(\d\d ?\d\d\d) ([a-z- ]+?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
61, avenue de Gauthier
81 516 Michel-sur-Paris
6, boulevard de Nguyen
02 998 Techer
boulevard Lucie Bouvet
16 345 Morel-sur-Marques
7, impasse Francois
29172 Deschampsnec
30, place Lucy Guillot
94 786 Texier-sur-Rolland
rue de Pruvost
91 147 Brun
boulevard Amélie Martin
56243 Godard
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)