# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d*?)(?:, )?([a-zéèàçù -]+?)\n(\d\d ?\d\d\d) ([a-z- ]+?)$"
test_str = ("61, avenue de Gauthier\n"
"81 516 Michel-sur-Paris\n\n"
"6, boulevard de Nguyen\n"
"02 998 Techer\n\n"
"boulevard Lucie Bouvet\n"
"16 345 Morel-sur-Marques\n\n"
"7, impasse Francois\n"
"29172 Deschampsnec\n\n"
"30, place Lucy Guillot\n"
"94 786 Texier-sur-Rolland\n\n"
"rue de Pruvost\n"
"91 147 Brun\n\n"
"boulevard Amélie Martin\n"
"56243 Godard\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.