use strict;
my $str = '61, avenue de Gauthier
81 516 Michel-sur-Paris
6, boulevard de Nguyen
02 998 Techer
boulevard Lucie Bouvet
16 345 Morel-sur-Marques
7, impasse Francois
29172 Deschampsnec
30, place Lucy Guillot
94 786 Texier-sur-Rolland
rue de Pruvost
91 147 Brun
boulevard Amélie Martin
56243 Godard
';
my $regex = qr/^(\d*?)(?:, )?([a-zéèàçù -]+?)\n(\d\d ?\d\d\d) ([a-z- ]+?)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}