using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w*동\b";
string input = @"대전광역시 서구 탄방동 홈플러스"",""대전광역시 동구 효동 주민센터"",""대전광역시 대덕구 오정동 한남마트"",""대전광역시 동구 자양동 87-3번지 성동경로당"",""대전광역시 유성구 용계로 128";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}