import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\w*동\\b";
final String string = "대전광역시 서구 탄방동 홈플러스\",\"대전광역시 동구 효동 주민센터\",\"대전광역시 대덕구 오정동 한남마트\",\"대전광역시 동구 자양동 87-3번지 성동경로당\",\"대전광역시 유성구 용계로 128";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}